네트워크 접속을 위한 라우터
네트워크와 네트워크를 접속시키기 위한 통신기기를 라우터라고 하며, 네트워크의 집합체인 인터넷은 바로 이 라우터에 의해 연결된 네트워크라고 할 수 있다. 여기에서는 라우터의 구조에 대하여 살펴보기로 한다.
수신한 패킷을 가까운 라우터로 중계
두 대의 PC가 인터넷을 경유하여 통신하는 경우를 예로 들어 라우터의 역할을 살펴 보자.
우선 송신원인 PC A는 보내고자 하는 데이터를 패킷이라고 불리는 데이터로 분할한다(그림 1). 이때, 송신원 A는 패킷 앞부분에 자신의 IP어드레스와 송신지인 B의 IP어드레스 정보를 헤더로 부가하여 LAN상으로 송출한다.


LAN상의 라우터는 이 패킷을 받아, 먼저 패킷의 헤더 속에 있는 송신지 IP어드레스, 즉 PC B의 어드레스를 점검한다. 다음은 이를 근거로 PC B에 보내기 위해 경유해야 할 라우터를 검색하고 패킷을 중계한다. 이와 같이 경로를 선택하는 동작을 라우팅이라고 한다.
패킷을 받은 라우터는 마찬가지로 라우팅을 하고 다시 다음 라우터로 중계한다. PC B와 같은 세그먼트(segment)에 있는 라우터가 패킷을 받으면 패킷은 PC B에 보내진다. PC B는 패킷에서 헤더를 제거하고 재결합하여 원래의 데이터로 복원한다.
라우팅 테이블이 송신지를 결정한다
라우팅에서 중요한 것이 송신지에 가장 가까운 라우터를 선택하는 일이다. 중계 라우터가 네트워크적으로 멀리 떨어져 있으면 송신지에 패킷이 도달하기 어렵게 된다. 따라서 라우터는 송신할 라우터를 자동선택하는 구조를 갖추고 있으며, 그것이 라우팅 테이블이다(그림 2).

라우팅 테이블은 인터넷상의 길잡이라고 할 수 있는 일람표로서 송신지의 IP어드레스와 여기에 네트워크적으로 가까운 라우터의 IP어드레스의 대응을 표시한 것이다. 패킷을 받은 라우터는 라우팅 테이블을 검색한다. 그 결과, 네트워크적으로 가장 가까운 라우터가 재송신지로 선택되는 것이다. 검색 결과에 따라 같은 거리의 라우터가 복수로 있는 경우에는 중요도 측정 정보로 어느 한 쪽을 선택한다. 이러한 측정은 송신지까지의 라우터의 수 등으로 표시되기 때문에 매트릭이라고도 한다. 예를 들면, 경유하는 라우터의 수가 적으면 송신지에 가깝다고 라우터는 판단한다.
라우팅 테이블의 설정은 수작업으로도 할 수 있다. 그러나 통상은 라우터끼리 서로 라우팅 테이블을 자동적으로 교환하는 라우팅 프로토콜이 사용되고 있다. 인터넷과 같은 무수한 네트워크의 정보를 사람이 일일이 관리하는 것은 비현실적이기 때문이다.
간단한 용어해설
☞ 라우터
LAN간 접속장치의 일종. 라우팅 기능을 갖으며 OSI 기본참조모델의 제3층(네트워크층) 프로토콜을 처리한다. 간선 LAN의 노드, 이기종 LAN의 접속, WAN 접속, 경로의 2중화 등 폭 넓은 용도로 사용된다. TCP/IP 프로토콜에 대응하는 제품을 IP라우터라고 하는 경우도 있다.
☞ 패킷
컴퓨터가 네트워크를 통해 데이터통신을 하는 경우 데이터의 집합. 원 데이터를 적당한 크기로 분할하여 송신원과 송신처 컴퓨터의 IP어드레스, 데이터 순서 등이 앞부분에 부가되어 있다.
☞ 헤더
패킷 앞부분에 부가시켜 통신에 이용하는 제어정보. IP레벨 뿐 아니라 이더넷이나 TCP레벨에서도 헤더가 붙는다. 이더넷 카드간이라도 하드웨어 레벨에서는 이더넷의 헤더가, 라우터간의 IP통신시에는 IP의 헤더가 사용된다. 브라우저와 WWW서버간 등 어플리케이션 레벨에서는 TCP나 UDP의 헤더가 사용된다.
☞ 라우팅 프로토콜
대표적인 라우팅 프로토콜에는 RIP(routing information protocol, RFC1058), OSPF(open shortest path first, RFC1583), BGP4(a border gateway protocol 4, RFC1771)이 있다. RIP은 중소규모의 네트워크에서, OSPF는 중규모 네트워크에서 사용되는 것이 많다. BGP4는 인터넷 접속사업자(프로바이더)사이에 사용된다.
비씨파크 주식회사, 대표이사 : 박병철 개인정보보호책임자 : 박병철
사업자등록번호 : 114-86-19888 |
본사 : 서울특별시 서초구 서초대로73길, 42, 1307호
전자우편 : master@bcpark.net |
(전화전 이용문의 게시판 필수)
전화: 02-534-982구(09:00~18:00) |
팩스: 02-535-155구 |
긴급: 010-9774-988삼
ㆍ저작권안내 : 비씨파크의 모든 컨텐츠(기사)는 저작권법에 보호를 받습니다. 단, 회원들이 작성한 게시물의 권리는 해당 저작권자에게 있습니다. 비씨파크에 게재된 게시물은 비씨파크의 입장과 다를 수 있습니다. 타인의 저작물을 무단으로 게시, 판매, 대여 또는 상업적 이용시 손해배상의 책임과 처벌을 받을 수 있으며, 이에 대해 책임을 지지 않습니다.
ㆍ쇼핑몰안내 : 비씨파크는 통신판매중개자로서 상품 주문, 배송 및 환불의 의무와 책임은 각 판매 업체에 있습니다.
Copyright ⓒ 2000-2026 BCPARK Inc. All Right Reserved.